You are Viewing : HomeDefaultTroubleshooting Synergy(Keyboard Mouse sharing) problems

Troubleshooting Synergy(Keyboard Mouse sharing) problems

I previously posted an article on installing synergy on multiple operating systems. If you don’t know what synergy is, you may want to proceed over here and take a look. It is a keyboard mouse sharing via network, simply put. This article deals with the problems that frequently/occasionally occur on getting synergy working.

Come on, who do want to use 3 Keyboards/mice at once? Well, I don’t. Using synergy quite a while on 3 of my computers – an iMac,  a Windows 7 PC  and Ubuntu(10.10) powered one, i wish to say that’s a geek’s advantage.

If you have not downloaded Synergy yet, now is the time! Get this awesome free-open source software over here.

Common problems

Synergy’s status can be found with the tray(Windows)/Menu(Mac) icon.

synergy_loaded or  StatusRunning denotes that Synergy has started.

connected or  StatusConnected Synergy denotes Successful Client-server connection.

Chances are that you never saw the second one, eventually got frustrated and gave up. But trust me, Synergy is more worth the buck.

Synergy or StatusWarning Warning : Failed to connect to server : Connection Refused

This happens when the client tries to connect to the server, which is turned off. Or, synergy server is not running.

Solution :

  • Start Synergy on the server computer and make sure it is configured correctly. That should fix the issue.
  • If the above does not work, double check your firewall/Antivirus.
  • Make the synergy auto start at login or power-on. For example, in windows :


Connection timed Out

Cause : Most often, Firewall/Antivirus on the server is blocking your connection attempts. Sometimes, the server maybe down or crashed/Unresponsive (relatively common on windows :-P ).

Solution : Synergy uses the port 24800 for its communication. That port needs to be free/unblocked in the firewall.

  • Open your Antivirus/Firewall configuration and allow the port 24800 through the firewall. If you are not sure about how to open the port in your specific brand of Antivirus/Firewall, do a google search with the keywords Open port in ‘_ANTI_VIRUS_FIREWALL_NAME_HERE_’ . I use ISP branded F-Secure, which conveniently offers an option “Open a Port” in its Internet shield settings.
  • If the above solution does not work, check whether the server computer has crashed or Locked. If so, you need to restart it.

Server already has a connected client with name “Client_Name”

Cause : Two computers unintentionally given the same screen name(by which server identifies).

Solution :

  • Change the name of one computer and try to reconnect.
  • If not, restart the synergy server. That is done by right clicking Tray icon –> quit synergy and Start menu –> Programs –> Synergy+ –> Synergy+

Make Video / Games stay Full screen with synergy

Cause : Most video and games applications needs to be on Focus when viewed full screen. When the focus is lost, obviously they leave full screen to window mode. Synergy on moving the cursor to the next screen(that is to another computer), captures the focus on the previous screen and takes foreground. So video applications/Games on losing focus, leaves full screen or minimizes.

Fix :

Windows : Open the synergy main window and click options. Usually the last one is “Don’t take foreground window on windows servers” . Check and start the server.


Cannot initialize Hook library : Synergy already running?

Cause : You are trying to run another instance, while it is already running on the background.

Fix :

  • Try connecting the clients. Unless synergy has crashed, it should connect promptly.
  • If it does not, Open Task manager and look for synergys.exe under processes. Right click and choose to end the process.
  • If the above does not work, open command prompt(Windows +R keys–> Type “Cmd”->enter) and enter the below command. That should do it.

 taskkill /IM synergys.exe /F 

If it still doesn’t work, try gaucho’s tip, the first comment below.

not_running Synergy : Not running / Synergy blocked tray icon

Synergy configuration / Firewall & everything seemed perfect. Yet, I faced this strange problem one day. Synergy tray icon showed a “blocked” symbol – i.e Red circle with a Diagonal line. I tried reconfiguration & reinstalled synergy numerous times, which was of no help.

Cause : You probably installed an additional input Language in your windows PC. And synergy is incompatible with some of the language’s characters.

Fix : None other than removing the input language that’s conflicting. :-(

Hopefully this will be fixed, I presume. If anybody figured out a workaround, please share.

Other Problems

Synergy : Cannot read configuration

Cause : Something wrong with/in the Synergy configuration file.

Fix : If you typed the configuration file, Check for any typos and correct Section : name ……. End syntax. Otherwise, delete the configuration file and redo.

Cannot move cursor back to the other/previous screen

Cause : Unintentional wrong configuration. Trust me, it may get confusing sometimes.

Fix : Correct the configuration. In recent/beta versions of synergy, It is easy – just as arranging the monitor icons in exact order. If you have older version, proceed.

Synergy Configuration Revisited

Example :

You have two computers – For example iMac and Windows 7 Dell. Imagine those as two persons (or gals maybe :-P ) standing next to each other.

  • For iMac, dell is on the left. For Dell, iMac is on the right.
  • Otherwise said, Dell is right of iMac. iMac is left of Dell.

i.e. relative to them. Likewise, relative to the computers. And not relative to third person/us. Got it? :-D

So synergy configuration window – Click [New Link] and below the box, Enter the correct configuration like in the example above. That should do it.

My previous detailed post on Synergy Installation and configuration in Windows, Mac OS and Ubuntu Linux can be found here.

United, we rule.

Kavin. :-)

  • Gaucho

    This is for the Googlers having “Cannot initialize Hook library” that are not solved by the above suggestion… On Windows 7 x64 I kept having this problem when I stopped and tried to restart synergys and only a reboot would fix it which was quite inconvenient – but I just found that if you ctrl-alt-del and then “Switch Users”, but then actually log back in to the existing session for the same user – it resets the screen so that synergy can then initialize the library properly. Works like a charm for me now… hope this helps someone else!

    • kavin

      Thanks for the tip. What synergy version are u using, BTW?

    • Amit

      Thanks a MILLION! you are a time saver with that SOLUTION.

  • nixx

    IU am experiencing a very weird behavior with Synergy. I have used it a lot in the past on different configurations so I don’ think its a config issue.
    Here’s what happens:
    I configure my server on an Ubuntu 11.10 machine, say “Ocelot”
    I have a client machine on the right, running Lubuntu 11.10, say “kitten”
    I configure kitten to connecto to Ocelot’s IP
    I configure Ocelot to “know” the screen on the right, as kitten

    The first time it works: I can move the mouse from ocelot to kitten as expected, and I can move back to ocelot. But then I cannot go back to kitten anymore. Stop synergy on both computers, re-start, re-configure, and it repeats: I can go to kitten once and go back, but then it stops working… No blocked connection in the fw log on any computer…

    Any idea ?



    PS: I’ll post back if I get it fixed

    • Kavin Gray

      Hai Nixx, sounds like you got the config wrong.. If you want to move the cursor around the far edges, then you have to set each system at either side.

      • Nicolas Selleslagh


        Turns out that Synergy actually works, but switching from the server to the client only works by “hopping” above the screen edge with the mouse. getting back from the client is no problem… I’ll keep searching but this is already much better !



  • Mnor86

    Am using synergy to connect a Windows 7 (as a server) and a Macbook pro 10.6 (as a clint) , but i keep getting an error msg says “cannot open primary screen: unable to open screen” whenever i hit the start button on the server. 
    what’s wrong here ??


    • Kavin Gray

      Hmm this issue occured to me recently with the new version of synergy. I went back to previous version, it solved it. I suggest you try the newest update if you are not using it, if not try a older version. :)

      BTW – did you use the gui or did the configuration by hand?

  • Prasad

    Thanks a lot. I got it solved after reading this blog section 
     Synergy : Not running / Synergy blocked tray icon
    helped me

    Sri Lanka

  • Rinoboy

    I am up and running just fine, with a singular exception: The mouse behavior is as expected, but each computer still uses it’s own keyboard.

    Any ideas?

  • Nish511

    My synergy works fine, but the problem is the mouse does not span through full linux windows. I have dual monitor setup on my linux machine and I am using synergy to share keyboard and mouse with windows 7 laptop.

    Windows 7 laptop is on right of the linux monitors. When I move mouse to right it just goes half through the screen and switches to windows 7 laptop. Any idea how to resolve it to span through full screen before it switches?

    Thanks for any advise.

  • Graugnom

    I also want to thank you for your hint for the problem “Synergy : Not running / Synergy blocked tray icon” with the red circle. I spent many days in finding out whats the problem. It was the arabic language which Synergy doesn’t like. After deleting it every thing works fine. Thanks!!!

  • Edmeister

    Hey Kavin…
    Frustrated…installed Synergy on both desktop and laptop…however even though the taskbar icon states successful connection…my mouse will not even move FROM the server monitor to the client…if you are going to reply please tell in a stupid simple  way that I can correct this…been @ this for hours close to not even bothering?….thanks John.

    • kavin

       @Edmeister That is probably because monitor order was not entered correctly. Please verify that, and try turning off security apps temporarily and see if that resolves the issue. :)

  • Nicole Rhoads

    Thanks so much for this! I’ve been trying to figure out why Synergy wouldn’t start (I changed the logging level to debug on my server, then added the port (as you detailed above) to the firewall exceptions and now it works! My wrists are very grateful! Thank you Thank you!

  • Ben Anderson

    FYI, current versions have problems with Win7 and certain windows being in the foreground; they will prevent the mouse leaving that screen. It’s not a misconfiguration issue; switching to an unaffected window allows you to change screens again, without restarting anything.

  • jaybhagwan singh

    How can I Insert image on tab button, using WP UI Plugin on wordpress Download Version 0.8 ….plz help me….

  • Tobi

    hello, i’ve been using synergy only recently, i stumbled upon this nifty tool and love how it workED for me. as long as i have a desktop running the server, i can share mouse and keyboard perfectly fine, but when i try to have the server run on my laptop, i get mouse function and copy/paste function, but can not use any keyboard, neither built-in keyboard, nor an extra keyboard work. i know it seems petty, but i’ve tried using older versions synergy and still no dice! help me figure this out please!!

    v 1.4.17 currently on windows 64bit

  • Manuel

    Hi, I´ve just installed Synergy. I connected server and client, but I´m experiencing a problem. When writing in the server everything goes ok, but when I use the keyboard for writing in the client some keys are wrong (for instanse I get a “s” letter when pressing the spacing key). This is annoying and I do not know how to solve it. Any help? Thanks!!

  • puncher72

    I use two laptops, both on Windows English 10, lets name them red laptop and green laptop. Both have two languages installed, US English and Greek (not only keyboard functionality but also system language installed). Default is US English. I also have set USA as country in regional settings just to be ok with Synergy although I am not in USA.

    I have a wireless combo of mouse & keyboard. I don’t have USB port functionality on the green laptop (broken ports). Because I write my reports (using English and Greek) on the green laptop and I want to be faster I want to use the combo instead of the touchpad and built-in keyboard. I have the combo connected to the red laptop (server) and use Synergy, so I will have the combo functionality on the green laptop (guest) as well. Let me describe now the issues.

    Wireless mouse work perfectly on green through Synergy. Fast and precise. The problem is with the keyboard transfer. When I want to type in English on green using Synergy (using either the built keyboard in red laptop or the wireless keyboard) everything works perfectly. No mishaps or letters inconsistency.

    1) In the first case I have English keyboard activated on red and switch to green. When I change the language to Greek (using either alt+shift from red or green or wireless keyboard) then I cannot use Greek on green. I want to be tell you that when I do that of course the language does not change in red laptop as it should. I have Greek activated on the bottom right (ΕΛ) but when I try to type in instantly turns to ENG and types English characters wherever I type. This happens to every software I have.

    2) In the second case – and after reading online Synergy solutions – I close the server on red, change the keyboard to Greek on red and switch to green. When I change then the language to Greek (using either alt+shift from red or
    green or wireless keyboard) then I cannot use Greek or English anymore on green through the red built-in keyboard or wireless keyboard. Only built-in green keyboard works. Whenever I try to type, it does not type anything at all, like the keyboards do not work.

    I really do not know how to fix it. I tried many solutions online, like resetting keyboard settings on server, quit and restarting server and nothing works. Do you have an idea?

    Thank you for any response.